Announcement

Collapse
No announcement yet.

Win 7 -- "New Text File" not showing up on right-click

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Persuasion
    replied
    You did help a lot with this info. I had this situation for couple of days and I though that my windows is hacked or got some bad errors althou it wroked well as previously. Just was thinking to reinstall it. Thanks again!

    Leave a comment:


  • SeedGuardian
    replied
    Thank you so much this was well needed!

    Leave a comment:


  • TKoL
    replied
    For the record, you can do this with just about any kind of file. I used the same method for .html and .css -- when I right click in windows explorer, it now says "Create new html doc" and "create new css doc"

    Leave a comment:


  • DESPAiR
    replied
    This was useful.

    Thanks man.

    Leave a comment:


  • TKoL
    started a topic Win 7 -- "New Text File" not showing up on right-click

    Win 7 -- "New Text File" not showing up on right-click

    By default, before you've mucked around with your system, when you right-click in an empty space in Windows Explorer in Windows 7, and hover over "new", you'll see a list of things you can create new: new folder, new word document, new excel sheet, and normally New Text Document. However, for many people who install a different program for editing .txt files than the default windows one (such as Notepad++, in my case), you might soon find that New Text Document no longer appears when you right-click and hover over "new".

    The problem is in the Registry.

    Open your start menu, type in "run" in the search bar and press enter. Type in "regedit" in the screen that pops up and press enter. This brings up your registry.

    Navigate to HKEY_CLASSES_ROOT, expand it, then navigate to the .txt subfolder. Click on the .txt subfolder. In the right screen, check the value of "Default". It should be "txtfile". If it's not, right click on "Default," choose "Modify" and change the value to "txtfile"

    In the right screen in the same place, check the value of PerceivedType. If it doesn't exist, right-click in the right screen and click new > string value. Name it PerceivedType, right-click on it, and change the value to "text"

    Expand the .txt subfolder. Click on ShellNew (if it's not there, right-click on the .txt subfolder > new > key and create one with the name ShellNew). With ShellNew selected, look in the right screen and check that there is an entry called NullFile. If there is not, create one by right-clicking and selecting new > string value. There's no need to enter a data value here.

    Hopefully, this will have solved your problems! You should be able to right-click and find new > New Text Document without restarting.
Working...
X