Announcement

Collapse
No announcement yet.

Clean Windows 7 and Ubuntu install lags

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Clean Windows 7 and Ubuntu install lags

    So I just finished last year in school and we get our laptops for free. My laptop started to lag like hell in the last weeks of school but I thought a clean install would fix this.
    I have checked the harddrive and there is nothing faulty there.

    I have a 20 GB partition with Ubuntu installed and a 300 GB partition with Windows 7. I also have a 4 GB swap partition for Ubuntu.

    When I start the computer (Ubuntu or Windows, doesn't matter) the cpu usage rises to close to 100% and the computer lags like hell. The fan starts to spin at one million rpm.

    HP ProBook 4520s with 4 GB ram installed

    Both operatingsystems are 64-bit

    The Windows install my school had was 32-bit.

    Any help would be fantastic!! =)

  • #2
    Sounds like something is leaking memory or is hanging and asking for a sh*tload of memory or it just starts and stops a 100 times leaving the program running where it crashed.

    Can't really do much without full system dumps and such but I assume uninstalling both OSes would be ideal or uninstall ubuntu and see what happens, scrub the partition and create new ones and so on and so on.


    sigpic
    _.-=' Special thanks to SiniuS for making me VIP and to Gblaze for graph work :)
    '=-._







    Comment


    • #3
      I did create new partitions when I reinstalled and it could not be an application in both Windows and Ubuntu that keeps crashing, can it?

      I am going to open it up and see if there is a lot of dust, maybe it is getting to hot! =)

      Comment


      • #4
        Can you tell what process is causing the CPU to go up to 100%? It's strange that both OS's will both do it, the only way that could happen is if it's a coincidence with different start up scripts on both systems or a hardware problem.

        Comment


        • #5
          Format the hard drive and install the new windows 7 32bits.


          Success!

          Comment


          • #6
            The hard drive has been formatted twice and I did a memory test, stopped it after 50 % with 0 errors. Gonna do full test this night.

            I will never install a 32-bit Windows, and I had the same problem when I had 32-bit so that is not the issue.

            The cpu cores is between 45-60 degress C.

            Comment


            • #7
              @Zephir, if the processor supports a 64-bit instalation, there's no need to rever to a 32-bit one.

              @Util1ty, memtest is only usefull if run several hours (and several cycles). With just half cycle is hard to tell there's a problem or not. Also if RAM fails in Windows, it will give you a BSOD almost 99% of the cases. As for the 100% CPU problem, I would suggest you try to run a Live Linux, like SystemRescueCD and see if that distro also makes the CPU spike to 100%. That way you can see if the problem might be from the laptop or the installation itself.

              Comment


              • #8
                Originally posted by Peternack View Post
                @Zephir, if the processor supports a 64-bit instalation, there's no need to rever to a 32-bit one. @Util1ty, memtest is only usefull if run several hours (and several cycles). With just half cycle is hard to tell there's a problem or not. Also if RAM fails in Windows, it will give you a BSOD almost 99% of the cases. As for the 100% CPU problem, I would suggest you try to run a Live Linux, like SystemRescueCD and see if that distro also makes the CPU spike to 100%. That way you can see if the problem might be from the laptop or the installation itself.
                I did run the "test ubuntu" before I installed and it lagged like hell as well but I thought it did that because I ran it from a live USB.

                Comment


                • #9
                  Originally posted by Util1ty View Post
                  I did run the "test ubuntu" before I installed and it lagged like hell as well but I thought it did that because I ran it from a live USB.
                  That happened to me when I first installed Ubuntu 9.04 (Happily on Mint after getting burned by 9.10's different look).

                  Maybe the Windows 7 install is causing something to go wrong? If you got a copy off TPB, try a better rip or forego Ubuntu until you can figure the problem out.


                  Sorry for not being more helpful, good luck with this odd problem :)
                  +*+*+*+
                  Was away from torrenting, this website and private trackers since 2014 (Maybe longer). Apologies if my inactivity has harmed you, but, I had family matters to attend to

                  Comment


                  • #10
                    Can of compressed air to clean it ? It's really an odd problem. If it's lagging a lot with a Linux LiveCD, maybe reinstalling the firmware for the BIOS would help too. Try a LiveCD with a usb key too, in case it's the DVD reader which has problems.

                    Comment


                    • #11
                      Originally posted by Vizor View Post
                      Can of compressed air to clean it ? It's really an odd problem. If it's lagging a lot with a Linux LiveCD, maybe reinstalling the firmware for the BIOS would help too. Try a LiveCD with a usb key too, in case it's the DVD reader which has problems.
                      I was using a LiveUSB, it lagged hard! :P

                      I decided to remove the Ubuntu partition, it did screw up grub hard so I had to use windows recovery to recover mbr :P

                      I have an idea of whats can be the problem... When I try to start a videofile in vlc or wmp the cpu starts running at 100%. Does my computer try to render the movie using the cpu instead of the gpu? I have CCC installed and the proper grapics drivers...

                      Comment


                      • #12
                        VLC doesn't use the GPU by default, you need to manually configure it to do so : VLC - Use GPU Acceleration

                        Is your computer only lagging when playing video files? If it's a Blu-Ray, that uses a lot of CPU, it would be normal. I tought your computer was lagging whatever you were doing, like booting, opening up notepad and stuff like that.

                        Comment


                        • #13
                          What you can do is try and run things in DXVA mode if your comp is to slow to render big ass videos.
                          No idea where the option is in VLC since I generally use MPC but the VLC plugins should support it.

                          If you're running windows you can get MPC aswell, just google k-lite codec pack, you'll have all the codecs you need aswell.

                          If all else fails just run XBMC on it, that played 1080p on my sh*tty old laptop without lagging at all lol.


                          sigpic
                          _.-=' Special thanks to SiniuS for making me VIP and to Gblaze for graph work :)
                          '=-._







                          Comment

                          Working...
                          X