Announcement

Collapse
No announcement yet.

autodl-irssi Not Grabbing Anything

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • autodl-irssi Not Grabbing Anything

    Hi,

    I have a Kimsufi 2G seedbox configured using [MENTION=127589]Copper[/MENTION]'s sticky in the seedbox tutorial section. It works just fine and I can add, download and seed torrents without problems.

    However, when I try to add my filters for autodl-irssi I get a handful of errors in the log and nothing gets downloaded when my shows air/pre. Here's an example of what I get when I add or edit a filter:

    10:50:49 -!- Reading configuration files
    10:50:49 -!- ERROR: /home/<username>/.autodl/autodl.cfg: line 5: OPTIONS: Unknown option 'rt-dir'
    10:50:49 -!- ERROR: /home/<username>/.autodl/autodl.cfg: line 5: OPTIONS: Unknown option 'rt-label'
    10:50:49 -!- ERROR: /home/<username>/.autodl/autodl.cfg: line 5: OPTIONS: Unknown option 'max-downloads'
    10:50:49 -!- ERROR: /home/<username>/.autodl/autodl.cfg: line 5: OPTIONS: Unknown option 'max-downloads-per'
    10:50:49 -!- ERROR: /home/<username>/.autodl/autodl.cfg: line 5: OPTIONS: Unknown option 'rt-rtorrent'

    If anyone can shed any light on this it would be greatly appreciated as it'd help if I could get in early on things to let me seed more where possible.

    Thanks.

  • #2
    The first few lines of your autodl.cfg file should look something like this:

    The password, port and nickname must match the ones in the conf.php file. I assume you didn't fill those in and directly started with the filters itself.
    If everything else is configured properly, your bot IS monituring the IRC channels, you added the passkey and the filters are reasonable wide, it should work.

    If I directly take it from Coppers tutorial it should look something like this:

    Configure Autodl-irssi passwords.
    Edit the /var/www/rutorrent/plugins/autodl-irssi/conf.php file to add a port and password.
    sudo nano /var/www/rutorrent/plugins/autodl-irssi/conf.php



    Replace the content of conf.php file with the following
    You can change the port number and password to ones of your choice.
    <?php

    $autodlPort = 38800;
    $autodlPassword = "fab7Rxtpp";

    ?>



    Edit the ~/.autodl/autodl.cfg file
    cd ~/.autodl
    sudo nano autodl.cfg



    Copy the following content into the autodl.cfg file
    Note that the GUI port and password must match the ones from the conf.php file
    [options]
    gui-server-port = 38800
    gui-server-password = fab7Rxtpp

    sigpic
    If you need help feel free to PM me, but keep in mind that asking for an invite is not considered help.

    Comment


    • #3
      also, if you use * as your only filter, you can see if that will grab anything. the * filter is set to grab everything that is uploaded. if that filter doesn't grab anything, the issue is in your config file

      Comment


      • #4
        Originally posted by Magister View Post
        The first few lines of your autodl.cfg file should look something like this:

        The password, port and nickname must match the ones in the conf.php file. I assume you didn't fill those in and directly started with the filters itself.
        If everything else is configured properly, your bot IS monituring the IRC channels, you added the passkey and the filters are reasonable wide, it should work.

        If I directly take it from Coppers tutorial it should look something like this:

        Hi and thanks for taking the time to respond, both files were edited exactly as in the tutorial, I've starred out the passwords below but both they and the ports are the same.


        I have the upload type set on a per filter basis but I've tried it as a global preference too, should it be watchdir rather than rtorrent? That just seemed like the obvious choice.


        I've included the contents of both files below, it'd be awesome if you could find time to glance over them and set me know what I'm doing wrong...


        My conf.php looks like this:


        ?php


        $autodlPort = 36709;
        $autodlPassword = "********";


        ?>


        and my autodl.cfg looks like this:


        [options]
        gui-server-port = <port 36709
        gui-server-password = ********
        update-check = auto


        [tracker ipt]
        cookie = ************************************************** ********


        [server irc.iptorrents.com]
        port = 6697
        ssl = true
        nick = ************


        [channel irc.iptorrents.com]
        name = #ipt.announce


        [channel irc.iptorrents.com]
        name = #iptorrents


        [filter The Middle]
        match-sites = ipt
        shows = the middle
        resolutions = 720p
        max-downloads = 1
        rt-dir = /home/******/downloads
        rt-label = TV Shows
        upload-type = rtorrent
        max-downloads-per = week


        [filter Modern Family]
        match-sites = ipt
        shows = modern family
        resolutions = 720p
        max-downloads = 1
        rt-dir = /home/******/downloads
        rt-label = TV Shows
        max-downloads-per = week
        upload-type = rtorrent


        [filter Family Guy]
        match-sites = ipt
        shows = family guy
        resolutions = 720p
        max-downloads = 1
        rt-dir = /home/******/downloads
        rt-label = TV Shows
        upload-type = rtorrent


        [filter American Dad]
        match-sites = ipt
        shows = american dad
        resolutions = 720p
        max-downloads = 1
        rt-dir = /home/******/downloads
        rt-label = TV Shows
        upload-type = rtorrent
        max-downloads-per = week


        [filter The Cleveland Show]
        match-sites = ipt
        shows = the cleveland show
        resolutions = 720p
        max-downloads = 1
        rt-dir = /home/******/downloads
        rt-label = TV Shows
        upload-type = rtorrent
        max-downloads-per = week


        [filter Raising Hope]
        match-sites = ipt
        shows = raising hope
        resolutions = 720p
        max-downloads = 1
        rt-dir = /home/******/downloads
        rt-label = TV Shows
        upload-type = rtorrent
        max-downloads-per = week


        [filter The Real Housewives Of Beverly Hills]
        match-sites = ipt
        shows = the real housewives of beverly hills
        max-downloads = 1
        rt-dir = /home/******/downloads
        rt-label = TV Shows
        upload-type = rtorrent
        max-downloads-per = week


        [webui]


        [ftp]


        [irc]

        ---------- Post added at 05:42 PM ---------- Previous post was at 05:32 PM ----------

        Originally posted by IguessNot View Post
        also, if you use * as your only filter, you can see if that will grab anything. the * filter is set to grab everything that is uploaded. if that filter doesn't grab anything, the issue is in your config file
        Thanks! Am trying this now.

        Comment


        • #5
          just to be clear, use * in the match releases box of the general tab. also ensure all other filter categories are empty
          [MENTION=214728]R088[/MENTION]

          Comment


          • #6
            Changed my autodl.cfg so it now looks like this:

            [options]
            gui-server-port = 36709
            gui-server-password = ********
            upload-type = watchdir
            upload-watch-dir = /home/******/downloads/watch


            [tracker ipt]
            cookie = ************************************************** ******


            [server irc.iptorrents.com]
            port = 6697
            ssl = true
            nick = **********


            [channel irc.iptorrents.com]
            name = #ipt.announce


            [channel irc.iptorrents.com]
            name = #iptorrents


            [webui]


            [ftp]


            [irc]


            [filter Everything]
            match-releases = *
            match-sites = ipt


            No errors showed up in the autodl-irssi pane at the bottom of the ruTorrent window but nothing has been grabbed as yet. Will just wait and see if it grabs anything I guess...


            ---------- Post added at 06:05 PM ---------- Previous post was at 06:00 PM ----------

            Originally posted by IguessNot View Post
            just to be clear, use * in the match releases box of the general tab. also ensure all other filter categories are empty
            @R088
            Thanks for this, have done exactly as above and my autodl.cfg file now reads like above. Nothing grabbed at all yet though and IPT have added several torrents in the last few minutes...
            Last edited by R088; February 1, 2013, 02:12 PM.

            Comment


            • #7
              Originally posted by R088 View Post
              Thanks for this, have done exactly as above and my autodl.cfg file now reads like above. Nothing grabbed at all yet though and IPT have added several torrents in the last few minutes...
              In the autodl tab did you get a message similar to the following?
              Reading config file
              Monitoring channel ipt-announce
              ...
              Did you also insert the passkey?
              sigpic
              If you need help feel free to PM me, but keep in mind that asking for an invite is not considered help.

              Comment


              • #8
                Originally posted by Magister View Post
                In the autodl tab did you get a message similar to the following?

                Did you also insert the passkey?
                I get a message stating 'Reading Configuration Files' but nothing about monitoring any channel?

                It doesn't ask for a passkey in the IPT section of the Tracker preferences, just the cookie which I had to dig out of Safari's develop menu?

                ---------- Post added at 10:28 PM ---------- Previous post was at 09:53 PM ----------

                Went in to the tracker prefs and turned off SSL / changed port to 6667, got the following in the autodl-irssi pane now:


                Reading configuration files

                irc.iptorrents.com: Connection settings changed. Reconnecting!
                ERROR: irc.iptorrents.com Not monitoring channel #ipt.announce (disconnected)
                irc.iptorrents.com: Monitoring channel #ipt.announce (/join)

                ---------- Post added at 11:12 PM ---------- Previous post was at 10:28 PM ----------

                It works!

                Had to follow the instructions here to get the correct version for Ubuntu 12.04 and then undid the edit to MatchedRelease.pm from the original tutorial and presto, it started grabbing stuff as it was announced.

                Done away with the * filter now and have it set up to grab our shows again although none of them air for a few days so will have to wait and see if I've got the filters right.

                Thanks again to both of you for your help with this.

                Comment

                Working...
                X