Announcement

Collapse
No announcement yet.

Copying files with special characters?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Copying files with special characters?

    So I downloaded something and the name is in russian, CuteFTP won't recognize it because of the special characters so I obviously have to copy the files to a new directory with no special characters in the name using putty right? How do I do this though? cp 2010\ -\ На\ Крыльях\ Зова ~/private/deluge/data/alkonost I tried that, it did not work. I tried it with wildcard also like this: cp 2010\ -\ На\ Крыльях\ Зова\* ~/private/deluge/data/alkonost Sorry for the jumbled text, for some reason, since the day I signed up here I haven't been able to put things on separate lines. At least not by hitting enter.
    Last edited by Bluntedking; March 11, 2012, 07:43 PM.

  • #2
    The fastest way to get this right is using Bash completion. If you have putty, you could simply type partial of those words then hit the "Tab" key.

    Alternatively, you could wrap all those names inside a quote. like so:

    Code:
    cp "2010 - Ha Крыльях Зова" destination
    The quote method words with Bash Completion too, just type the double quotes then followed by 2010 and finally hit the Tab key.

    Comment


    • #3
      Try to find an option where you copy the binary representation rather than copying by characters (which usually copies by ASCII, which doesn't include all characters).

      Comment


      • #4
        Originally posted by boodog View Post
        Try to find an option where you copy the binary representation rather than copying by characters (which usually copies by ASCII, which doesn't include all characters).
        A most precise and better way to copying files would be accessing it through their inode number. Not sure if what you suggested could be found in Linux.

        Comment


        • #5
          Thanks guys. cp "2010 - blahblahblah" with tab worked. I also learned FileZilla works with the special characters but CuteFTP does not.

          Comment


          • #6
            Originally posted by Bluntedking View Post
            Thanks guys. cp "2010 - blahblahblah" with tab worked. I also learned FileZilla works with the special characters but CuteFTP does not.
            You probably need to manually set it to UTF-8 encoding in CuteFTP. Filezilla by default uses UTF-8.

            Comment


            • #7
              CuteFTP does not support UTF-8 currently.

              Comment

              Working...
              X