Announcement

Collapse
No announcement yet.

uTorrent "Not" filter question

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • uTorrent "Not" filter question

    I'm wanting to filter out all *.avi files from my feeds as I do not want those files downloaded anymore.

    In the "not" field I put in *xvid*|*avi*. However, this morning I still go torrents in avi format that downloaded. Any idea what I'm missing here?

  • #2
    Filter works for torrent names not for file name extensions, therefore your only option would be to create some smart filters in the "yes" field.

    Even if you would find a way to filter out file name extensions that will be useless because most files come in .rars.

    Also, even if you would manage to compare at least one rar file name to your filter there is a 50/50 chance that a real name of a file in the rar file will not match.
    Last edited by silentninja; November 3, 2011, 09:28 AM.
    sigpic

    Comment


    • #3


      I'd love to help, but there are too many missing details here to do more than randomly guess. Unless someone just happens has experienced the same problem and can fill in the missing pieces from their own experience.. The problem could be many things from a typo, to symbols, foreign character sets, or a bug.

      To begin to narrow the possibilities down, we'd need to know a lot more about your configuration e.g. what version of utorrent you are using, your other feed settings, the tracker, the full title of the download in question and any other relevant details. Silentninja has giiven you the most likely cause - that the container wasn't specified in the title string. If that isn't it, then at a guess, it might the use of underscores or other symbols in the title.



      Last edited by Copper; November 3, 2011, 09:23 AM.
      Fortune and love favour the brave .-. Ovid ....

      Comment


      • #4
        Currently using uTorrent 2.2.1. This only applies to TV Shows, so there are no rar files.
        If they don't work for extension would only using *xvid* work as that is listed in the name of all the AVI files I can see? Not sure if it's case sensitive as well.
        On the flip side I'm aiming at mainly MKV's vs AVI's, would a filter like *Hawaii Five-O""mkv" only pull mkv's? If so then I would not need to use the Not field.

        Comment


        • #5


          Thanks for telling us which version you are using, but you still didn't disclose any of the other details. I didn't ask for details to simply create work for you - it is essential to know that configuration if you want any real hope of troubleshooting this. The filter will not exclude avi or any other type of file unless that file type was explicitly stated in the title. So in that respect it does not matter if the filter is exclusionary or inclusive. Here is an utorrent change log, you could look to see if your utorrent version had any relevant bugs that were corrected in later releases.

          Due to the lack of information, all I can do is semi-randomly guess at the problem. Best guess: title did not specify container > incorrectly formatted filter > non-standard symbols in title



          Fortune and love favour the brave .-. Ovid ....

          Comment


          • #6
            Originally posted by copper View Post


            Thanks for telling us which version you are using, but you still didn't disclose any of the other details. I didn't ask for details to simply create work for you - it is essential to know that configuration if you want any real hope of troubleshooting this. The filter will not exclude avi or any other type of file unless that file type was explicitly stated in the title. So in that respect it does not matter if the filter is exclusionary or inclusive. Here is an utorrent change log, you could look to see if your utorrent version had any relevant bugs that were corrected in later releases.

            Due to the lack of information, all I can do is semi-randomly guess at the problem. Best guess: title did not specify container > incorrectly formatted filter > non-standard symbols in title
            My apologies, I got a bit ahead of myself there. Let me see if i can get all the information.
            Tracker: TV Torrents (TvT)
            Torrent Title: Mythbusters.S09E18.Drain.Disaster.HDTV.XviD-LMAO.avi
            Filter Settings: Filter - *Mythbusters*; Not - *xvid*|*avi*; Feed - TvT; Smart ep. Filter Checked; Quality - All

            Hope that covers everything you were asking for.

            Comment


            • #7
              Not
              Code:
              *avi|*xvid*
              case insensitive
              Code:
              *avi|*XviD*
              case sensitive

              Filter
              Code:
              mythbusters*
              case insensitive
              Code:
              Mythbusters*
              case sensitive
              Last edited by silentninja; November 3, 2011, 10:26 AM.
              sigpic

              Comment


              • #8
                Thanks I will give *avi | *XviD* a shot.
                I do have Mythbusters in my filter already for case sensitivity.

                Comment


                • #9


                  The syntax that Silentninja gave you is common practice for filters. Whether your version of utorrent recognizes case sensitivity, I don't know. The last time I looked, utorrent didn't, but that was several years ago and newer releases may well have added this. It would be very easy for you to confirm. Make a case sensitive filter that does not match a specific torrent. And see if it triggers or not.

                  I can tell you this much. I just configured utorrent 2.2.1.25302 with the configuration settings you provided and the NOT filter worked as expected. The torrent with "XviD" in the title on TVT was properly excluded.


                  Fortune and love favour the brave .-. Ovid ....

                  Comment


                  • #10
                    It could work just with
                    Filter:
                    Code:
                    Mythbusters
                    Not:
                    Code:
                    XviD avi
                    I am using different torrent client and this works for me, and it is on Linux! Therefore I think it should work with Utorrent too.
                    sigpic

                    Comment


                    • #11
                      This still doesn't appear to be working properly.
                      For example on TvT (FreshOn) Rules of Engagement still pulled the avi torrent.

                      Torrent Name: Rules.of.Engagement.s06e03.HDTV.XviD-LOL
                      Filter Not is set to: *XviD | *avi*

                      Not sure why this isn't working.

                      Comment


                      • #12


                        The not filter worked properly for me when tested with your original parameters:

                        uTorrent 2.2.1.25302
                        Tracker feed: TV Torrents (TVT)
                        Filter: *Mythbusters*
                        Not filter: *xvid*|*avi*
                        Quality: all
                        Smart ep. filter: on

                        Torrent: Mythbusters.S09E18.Drain.Disaster.HDTV.XviD-LMAO.avi
                        Result: excluded


                        Fortune and love favour the brave .-. Ovid ....

                        Comment


                        • #13
                          From what I can see here, Not in this case should be
                          Code:
                          *XviD*
                          because XviD is in the middle. I suggest you to try
                          Code:
                          XviD|avi
                          in future because from the looks of it if you set * that means that there should be at least one character there - basically you are saying to an RSS downloader to download somethinghereXviDsomethinghere and if there is no somethinghere it is being ignored.
                          Last edited by silentninja; November 6, 2011, 11:31 AM.
                          sigpic

                          Comment


                          • #14
                            Ok, I will try "XviD | avi" without the stars for tonights feeds and see if it properly filters them out.
                            Copper, maybe its because I didn't put a * after XviD, I will test both methods and see what will work.

                            Comment


                            • #15
                              If you are still having problems at this point. You could consider use the qBittorrent official website It has one of the most simple (advanced) RSS filtering I have ever encountered. This torrent client is seriously underestimated.

                              If you use qbittorrent and you want to download Epic.Drama.S02E03.1080p.HDTV.x264-ihasnets and your conditions are Epic S02 1080 then all you have to do is to create the following filter
                              Code:
                              Epic S02 1080
                              It works like a charm!
                              Last edited by silentninja; November 6, 2011, 03:56 PM.
                              sigpic

                              Comment

                              Working...
                              X