No announcement yet.

autodl-irssi installation help

  • Filter
  • Time
  • Show
Clear All
new posts

  • autodl-irssi installation help

    Hi guys

    I;m using pulsed media seedbox and trying to install autodl-irssi plugin. They have a wiki article but their support is limited when it comes to this plugin.

    So i installed the plugin, did the configuration :

    cd ~/www/rutorrent/plugins/
    git clone autodl-irssi
    cp autodl-irssi/_conf.php autodl-irssi/conf.php

    nano ~/www/rutorrent/plugins/autodl-irssi/conf.php

    $autodlPort = 6457;
    $autodlPassword = "Behy4ywsdgV";

    nano ~/.autodl/autodl.cfg

    [options] gui-server-port = 6457
    gui-server-password = Behy4ywsdgV

    and then

    screen -dmS autodl irssi

    I can see the plugin in my rutorrent toolbar but im also getting this error -

    [29.03.2021 11:04:01] Error downloading files. Make sure autodl-irssi is started and configured properly (eg. password, port number): Error getting files listing: Error: Could not connect: (111) Connection refused

    I know this is a common error and I already ruled out several issues like autodl is running -

    :~/.irssi/scripts/autorun$ screen -ls
    There are screens on:
    169769.autodl (03/29/2021 05:58:33 AM) (Detached)
    1786.rtorrent (03/20/2021 02:03:41 AM) (Detached)

    ~/.irssi/scripts/autorun$ ps aux | grep autodl
    xxx 169769 0.0 0.0 25676 2580 ? Ss 05:58 0:00 SCREEN -dmS autodl irssi
    xxx174878 0.0 0.0 12736 2224 pts/3 S+ 06:11 0:00xgrep autodl

    So autodl irssi is running and the config all correct but why am I setill getting this error? I tried few other random ports but no luck so far.

    Can someone confirm if my conf.php and autodl.cfg settings are correct? specifically the semicolon and the double quote marks etc?

  • #2
    oh and i've already tried restarting irssi several times it didnt fix the issue.. also made sure the pl file exists within the autorun folder


    • #3
      Yay i managed to fix the issue.. I'm just posting an update here so that if anyon else encountering this issue they can resolve it :

      Run these commands:

      ~ cd ~/.irssi/scripts
      ~ wget unzip -o
      ~ rm
      ~ cp autorun/
      ~ pkill -fu "$(whoami)" 'irssi' && screen -dmS autodl irssi