rutorrent create a torrent issue
Register

We are the best invite forum on the internet! Here you will find free invites, free seedboxes, free bonuses, and much more. Our members know the true meaning of sharing and have created a truly global bittorent community! Our site has the most up to date information on all private trackers and our members will guide you and introduce you to this truly secretive and enlightened club. Ready to get started? Register now!


User Tag List

Results 1 to 10 of 10
  1. #1

    Join Date
    Mar 2010
    Location
    canada
    Posts
    442

    Default rutorrent create a torrent issue

    Create a torrent in rutorrent was working till today. what happens is, i add all the info in create a torrent, click create, and it just idles. Not sure whats going on, very annoying... any help would be awesome.



  2. To remove ads become VIP. Inquire about advertising here.
  3. #2

    Default

    make sure your cofig file for the create plugin is correct. i suggest using mktorrent or buildtorrent and in the config for that if you do you also have to set it in the confige file for example if you use mktorrent and set the path as well in the config

    $useExternal = 'mktorrent';
    $pathToCreatetorrent = '/usr/local/bin/mktorrent';

    hope this helps
    I Love TI

  4. #3

    Default

    If you are attempting to create a .torrent file from a very large file (~5gb) and you have mktorrent as your client, it will not work. Rutorrent will just stall in this case.
    Use buildtorrent instead.

    Otherwise, it could just be that xmlrpc is slow to respond because your server is too busy.
    Last edited by scoobie; February 25th, 2011 at 09:54 AM. Reason: typo

  5. #4

    Join Date
    Mar 2010
    Location
    canada
    Posts
    442

    Default

    "cofig file for the create plugin is correct" not sure what you mean, i'm not using any plugins, just using whatever was preconfigured on my seedbox. I"ve never downloaded any plugins, and its worked fine up till today. If there are plugins you can add, where can i get them, or are they already installed i just have to enable them.

    Thanks again for the quick responses.

  6. #5

    Default

    You said it was working fine before and then it just stopped, assuming nobody modified or upgraded your server, then it should be something else and not the plugin itself.

    What kind of files are you attempting to create a .torrent file from? Do they have weird characters in their filenames? Are there subfolders that are nested deep relative to the parent directory where you're creating .torrent file from?
    It could be that mktorrent/buildtorrent is failing to create the .torrent file and it's not spitting out an error message that rutorrent can process, so it just sits there and wait.

    But if your rutorrent was upgraded, it's possible that some of the configuration files have been overwritten.

  7. #6

    Default

    I find that a restart of ruTorrent every once in a while doesn't hurt either, but in general the bigger the file the longer it will take.
    Cheers

  8. #7

    Join Date
    Mar 2010
    Location
    canada
    Posts
    442

    Default

    It's still not working, Here's the steps to create a torrent in rutorrent:

    Click create torrent
    Select Source
    Torrent Properties
    Tracker:
    Piece Size
    Click private torrent and start seeding
    Then i click create

    Its worked up till today. The file i'm trying to upload is only 30mb, so size isn't the issue. Nobody answers me on whatbox irc chan, i filled out a support ticket, no answer, its been like 12 hrs. Kinda defeats the whole purpose of using a seedbox if you can't upload to it.. lol

  9. #8

    Default

    You can't restart rutorrent(unless you mean the httpd?), you can restart rtorrent though. Also, you can only change these settings if you have SSH access to your seedbox to perform the necessary configurations.

    If so:
    compiling mktorrent:
    mktorrent - Create BitTorrent metainfo files from command line
    look for the build recommendations but disable PTHREADS when compiling.

    compiling builtorrent:
    buildtorrent-0.8 released :: ClaudiusMaximus

    buildtorrent is a lot more straight forward.

    Then go to your /var/www/rutorrent/plugins/create/conf.php file and change the settings mentioned by COD.
    Last edited by Synth; February 25th, 2011 at 08:13 PM.
    Retired and happy :)

  10. #9

    Join Date
    Mar 2010
    Location
    canada
    Posts
    442

    Default

    Yep rtorrent i can restart and i don't have SSH access. I'm just wondering if this is a common problem, or somebody who has had it and resolved the issue.
    Last edited by goodolday; February 25th, 2011 at 08:28 PM.

  11. #10

    Default

    It could also be that there are no more space left in the /tmp directory. The create torrent plugin uses it to temporarily create .torrent files. If you don't see this "Try to correct torrent file..." or this "Error." message in the message box after you click create .torrent tlhen it's an indication that it hasn't gone pass the create a folder stage in /tmp yet. Your best bet is to have your seedbox provider check it out for you since you don't have ssh access.

Similar Threads

  1. Help With ruTorrent & creating New Torrents
    By MearCat99 in forum Help
    Replies: 4
    Last Post: December 5th, 2010, 03:41 AM
  2. Replies: 5
    Last Post: September 7th, 2010, 11:38 PM
  3. How to use Gmail to create personal torrent search
    By theUkGreek in forum Internet
    Replies: 5
    Last Post: March 28th, 2010, 10:34 AM
  4. [Guide] Creating a .torrent with Utorrent
    By thedeh in forum Software
    Replies: 1
    Last Post: August 5th, 2009, 07:25 AM
  5. Replies: 1
    Last Post: August 2nd, 2009, 05:13 AM

Visitors found this page by searching for:

torrent invites

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •